NetGuard Pro – no-root firewall v0.81
Requirements: 4.0+
Overview: Network guard NetGuard is a simple block access to network applications – without having Root privileges.


NetGuard provides a simple way to block access to the internet – no root required.
Applications can individually be allowed or denied access to your Wi-Fi and/or mobile connection.

Blocking access to the internet can help:

• reduce your data usage
• save your battery
• increase your privacy


• No root required
• Simple to use
• Open source
• No extra battery usage
• No bandwidth reduction
• No calling home
• No tracking or analytics
• No ads
• No internet permission required
• IPv4/IPv6 TCP/UDP supported
• Optionally allow when screen on
• Optionally block when roaming
• Optionally block system applications
• Material design

There is no other no-root firewall offering all these features. Most other firewall solutions are closed source, will use extra battery and will reduce the overall network speed.

Most of these features are the result of sending selected traffic to a VPN sinkhole, instead of filtering all internet traffic. This means that advanced features, like address-based filtering (needed for hosts blocking), traffic logging, and on-demand configuration, are not possible.

Since NetGuard has no internet permission, you know your internet traffic is not being sent anywhere.

For up to date info on device compatibility, questions and answers please read more here:


ICMP support (depending a kernel ICMP socket support, probably no ICMPv6)
Search on port number in the traffic log
Option to disable access notifications per application (you probably want to disable this for your browser)
Lots of small improvements and minor bug fixes
Updated translations

A LIRE  Crusaders Quest v2.9.9.KG [Mods]

This app has no advertisements

More Info:

Code: Select all

Téléchargement Instructions: PRO features Unlocked


Finally, it’s now working on Jelly Bean and up!

Requirements: Android 4.0+

Mausje wrote:Finally, it’s now working on Jelly Bean and up!

Requirements: Android 4.0+


App fast crashes when setting is opened in jb 4.2.2